ГлавнаяФорумДневникиФотоальбомы

Войти через:
Новости Телефоны Игры Графика Программы Документация Еще ...


Программа Python 1.4.5 + MegaPyModulePack


Интерпретатор языка программирования Python для смартфонов Nokia. Помимо самого Python, архив содержит PythonScriptShell - консоль (иконка в меню), а также набор дополнительных модулей MegaPyModulePack, необходимых для работы большинства приложений написанных на Python.

[!] Файлы необходимо устанавливать только в память смартфона.
[!] Файл MegaPyModulePack необходимо подписать или устанавливать на смартфон с открытым полным доступом.
[!] Перед установкой, необходимо удалить старые версии Python, модулей и программы использующии Python.

Разработчик: PyS60
Скачать Python 1.4.5 + MegaPyModulePack
Программы для смартфонов
АвторСообщение
night_amir
1, добавлено: 28 Июл 2007 17:57
Все, кто думает, что Питон - это программа - сильно заблуждаются! На самом деле, питон - это язык программирования!
Более того, это интерпретированный язык. Это значит, что коды программ не требуют компиляции (если вы не знаете что это,
то не стоит забивать голову!
Кому интересно - читаем в википедии).
Программа, что называется "Python", которую вы устанавливаете на ваш смартфон - это интерпретатор кодов программ,
которые в дальнейшем устанавливаются на ваше устройство.


Установка питона и модулей:
Перед установкой убедитесь, что в памяти телефона есть примерно 500 Кб свободной памяти, ведь
Все составляющие питона (интерпретатор и модули) необходимо ставить в память телефона!

Итак, установка:
Помним, что все необходимо устанавливать в память телефона!
1) Устанавливаем интерпретатор Python. Скрытый текстТак как для запуска большинства приложений вам не потребуется непосредственный запуск питона, то устанавливать иконку запуска вам необязательно. Другое дело, если вам необходима консоль для программирования приложений. В этом случае вам необходимо поставить и Python Script Shell (всегда распространяется в одном архиве с питоном). Но Python Script Shell (с англ. - "лаучер скриптов") так же помогает запускать некоторые программы, распространяемые в виде исходного кода (это файл с расширением .py).
2) Устанавливаем модули. Ни в коем случае не пытаемся установить и MegaPyModulePack, и PythonRightPack одновременно! (да и не получится это! :-) )

Если в ходе установки что-то не получается, можно попросить помощи в этой теме!

Python 1.4.5 Final + MegaPyModulePack 2.0.1 - скачать

Скачать отдельно модули:
MegaPyModulePack 2.0.1
megaPyModulePack 1.5.2 - megaPyModulePack 1.5.2
Цитата:


Основной состав :
- модули: appswitch, cenrep, feature, fgimage, hack, iapconnect, keypress, misty, pathinfo, uikludges, uitricks, dialog, miso, misoalarm, pyextaccel, xprofile, lite_fm, minidb, easydb, mbm, powlite_fm, proshivka, rusos, fonts, prgbar, ftplib, prodb, clipboard, error, datetime, smidi, aes, _pyexpat, xml, akntextutils, envy, tsocket, RDAccelerometer, blues, aXYZ, pys60usb и др.;
- кодировки: cp1251, cp866, koi6_r, koi8_u

В этой сборке доработаны старые модули и, по большим просьбам трудящихся, добавлены модули PyBluetooth_teror and PySpeechy ...
Есть возможность выборочной установки необходимых модулей!


Файл необходимо подписать!
Устанавливать в память смартфона!

PythonRightPack 1.1.3 - PythonRightPack v 1.1.3
Цитата:
!!!С новым модулем keypress не хочет работать automan. На N73 и E61 понадобится установить немного измененный модуль clipboard (cтарый модуль keypress и модифицированный clipboard в архиве addons.zip)

Внимание:
1. Перед установкой этих модулей необходимо удалить предыдущий пак!
2. Устанавливать в память смартфона!
3. Подборка содержит RDAccelerometr.dll! Именно из-за неё может возникать ошибка обновления. Удалите файл из С:/sys/bin/ или удалите программы, связанные с акселерометром.
4. Необходимо подписать!


Python 1.9.0 - скачать!
Вышла версия Python for S60 1.9.0 на ядре Python 2.5.1.
Цитата:

* Добавлены следующие стандартные модули:
Expat XML parser, ftplib, smtplib, urllib2, xmlrpclib, SimpleHTTPServer, cPickle, asyncore и socket.
* Введена поддержка сборщика мусора.
* Улучшен all-in-one installer.
* Упрощена упаковка python приложений в sis (при помощи утилиты Ensymble).
* Дополнительные модули PyS60 socket и calender переименованы в btsocket и e32calender, чтобы избежать конфликта имен с модулями ядра.
* Приложения, упакованные в SIS файл, стали более отказоустойчивы:

1. если среда исполнения не установлена, будет отображено текстовое сообщение об ошибке
2. если при старте приложения произойдет исключение, сообщение об ошибке появится на экране (ранее сообщение не отображалось)
3. приложения имеют консоль, поэтому print выполняется точно так же, как и в script shell

* UID среды исполнения Python и PythonScriptShell изменился
* Директория PythonScriptShell теперь не C:python, а C:datapython
* Для того, чтобы обеспечить совместное сосуществование сред исполнения 1.4.x и 1.9.0, имена бинарных файлов в новой версии имеют префикс '251_'.

Недостатки:
* Прекращена поддержка S60 2-й редакции (там нет поддержки OpenC)
* Более длительная установка и запуск.
* Релиз работает с S60 5-й редакции, но еще не содержит модулей для доступа к Touch возможностям платформы
* По неясной причине среда исполнения не подписана сертификатом.

Формат документации изменен с pdf на набор html файлов.


Python v.1.9.7 - скачать

Python v.2.0.0 - скачать - Официально подписанная версия от 11 февраля 2010г
Порядок установки:
» у кого было установлен Python 1.4.5 и рядом 1.9.7 - удаляем последний;
» устанавливаем Python_2.0.0.sis, PythonScriptShell(соответствующий вашей оси) и MegaPyModulePack.v2.01;
» часть приложений написанных на Python возможно не запустится и потребуется их переустановка;

Удаление:
Удалять и питон, и модули ТОЛЬКО через диспетчер приложений!

Запуск скриптов (файлов с расширением .ру):
1) Копируем скрипты в папку C:\Python\.
2) Запускаем Python.
3) Левая софт клавиша - Запустить скрипт - выбрать необходимый скрипт.

Вопрос-Ответ:
В: При установке более новой версии Python и megaPyModulePack появляется ошибка обновления компонентов ("Update error")
О: Необходимо снести питон, модули и все программы и игры (написанные на питоне) через диспетчер приложений.

В: Установил питон и модули, но программы не идут! Что делать?
О: Проверить где установлены программы, питон и модули! Все должно устанавливаться в память телефона!

В: В питоне есть функция "interactive consol" для чего она нужна и как ею пользоваться?
О: Эта функция используется программистами! Кому интересно - смотрим!

Директории:
C:\Python\ - скрипты.
C:\resourse\ - модули.


Если вы установили Python 2.0.0 и у вас не работают программы на Python, то удалите Python 2.0.0 и установите Python 1.4.5. На данный момент это самая стабильная версия для Symbian OS 9.1-9.3.

warhazar2011
Новичок
НовичокПолезность: 0 (0)
Имя: Никита
Возраст: 22
С нами с: 05.08.2011
Сообщений: 20
Откуда: Казахстан, Караганда
Модель телефона: Meizu M3s 3/32,Nokia 500
0
736, добавлено: 21 Ноя 2011 17:25
Ani Menu ваще не запускается не с одной версией питона помогите чем сможете

XenON
Новичок
НовичокПолезность: 0 (0)
Имя: Александр
Возраст: 28
С нами с: 01.01.2009
Сообщений: 61
Откуда: Саратов
Модель телефона: Nokia 5800 Red
0
737, добавлено: 05 Дек 2011 21:11
однозначно что-то не так с этими питонами... прошил телефон, 5800 на последнюю модифицированную прошивку, портированную с с6 на 5800 (на базе 60-й проши для 5800), в диспетчере приложений ничего не установлено. ставлю питон 1.9.7 - на последнем компоненте пишет - компонент встроен. не устанвливается.
ставлю питон 1.4.5 потом поверх 2.0.0 - устанавливается все. но смарттач пишет что не хватает компонента питон рантайм, зато мэджикм3у - работает. ставлю питон без ПИПС - работает смарттач, но не работает мэджикм3у - пишет что не хватат питон рантайм. вообще беспредел, уже какой год не могу с этими питонами сделать все нормально!

Vikturist
NokiaMan
NokiaManПолезность: +268 (302)
Возраст: 64
С нами с: 27.09.2009
Сообщений: 2086
0
738, добавлено: 05 Дек 2011 21:30
XenON писал(а):
уже какой год не могу с этими питонами сделать все нормально!

Надо ОДИН раз почитать(и прислушаться к рекомендациям) ВСЕ, что написано в Шапке, тогда все будет работать.

P.S.Никогда не было проблем с Python,ом. :yes:

Vbif
Начинающий
НачинающийПолезность: +3 (3)
Имя: Михаил
Возраст: 27
С нами с: 08.02.2008
Сообщений: 105
Откуда: Укр., Днепропетровск
Модель телефона: Xiaomi Redmi 3S Pro
0
739, добавлено: 12 Дек 2011 15:26
Не удается установить MegaPyModulePack 2.01 - выдает сообщение "Ошибка при обновлении". Python 1.4.5 Встал нормально. Вот только не могу до конца поставить 2.0.0 версию
Не судите человека, пока не поговорите с ним лично, потому что все что вы слышите - слухи.© Майкл Джексон

zander42
Профи
ПрофиПолезность: +70 (80)
Имя: Александр
Возраст: 49
С нами с: 05.04.2008
Сообщений: 1226
Откуда: РФ, Ульяновск
Модель телефона: Dell Streak , Nokia E61-1
0
740, добавлено: 14 Дек 2011 05:44
Vbif писал(а):
Не удается установить MegaPyModulePack 2.01 - выдает сообщение "Ошибка при обновлении". Python 1.4.5 Встал нормально. Вот только не могу до конца поставить 2.0.0 версию

Ясно сказано в шапке :
night_amir писал(а):
Вопрос-Ответ:
В: При установке более новой версии Python и megaPyModulePack появляется ошибка обновления компонентов ("Update error")
О: Необходимо снести питон, модули и все программы и игры (написанные на питоне) через диспетчер приложений.

DIMAvBOSS
Новичок
НовичокПолезность: 0 (0)
Имя: Dima
Возраст: 40
С нами с: 02.06.2011
Сообщений: 28
Откуда: Укр., Кировоград
Модель телефона: Nokia 5800 Express Music
0
741, добавлено: 12 Янв 2012 20:53
Здравстввуйте! Помогите пожалуйста! У меня память в телефоне на С кончилась, я пытался установить прогу для очистки мусора NullDSel, но потребовалось установить Питон, что я успешно сделал, а вот MegaPyModylePack мне не позволило и написало что я его должен подписать... Подскажите что делать или какую-то другую прогу для очистки посоветуете? Заранее благодарю

vlaade
Новичок
НовичокПолезность: 0 (0)
Имя: vlad
Возраст: 21
С нами с: 14.01.2012
Сообщений: 10
Откуда: РФ, Уфа
0
742, добавлено: 17 Янв 2012 22:00
или взломай телефон или удаляй все вручную

sokol851
Новичок
НовичокПолезность: 0 (0)
Имя: ilia
Возраст: 24
С нами с: 26.09.2011
Сообщений: 3
Откуда: РФ, Санкт-Петербург
0
743, добавлено: 17 Мар 2012 20:16
Здравствуйте, как удалить полностью Python с Symbian, все куски и тд? Чтобы не было ничего связанного с ним.

Причина: Установил Python 2.0 поверх 1.4.5, после чего перестали запускаться некоторые приложения.

Цель: Удалить полностью битый Python, чтобы установить нормальный, более проверенный Python 1.4.5.

Тело: 5530

Опрос: какая версия Python лучше?

2.0.0 или 1.4.5


Или посоветуйте хорошую сборку Python для Symbian 9.4

Спасибо

Сброс не предлагать

android_man
Новичок
НовичокПолезность: 0 (0)
Имя: Владимир
Возраст: 34
С нами с: 08.03.2012
Сообщений: 6
0
744, добавлено: 27 Мар 2012 01:38
Товарищи подскажите пожалуйста, такая проблема. Раньше все работало и очистка и перезагрузка с помощью проги endclear, но потом не знаю что произошло при попытке перезагрузиться endclear пишет что "нет модулей switchoff и miso..."
Что это такое вообще ума не приложу.
Пробовал разные версии питона, устанавливал megaPyModulePack и никак не решается эта беда.
Помогите пожалуйста. Спасибо

sokol851
Новичок
НовичокПолезность: 0 (0)
Имя: ilia
Возраст: 24
С нами с: 26.09.2011
Сообщений: 3
Откуда: РФ, Санкт-Петербург
0
745, добавлено: 27 Мар 2012 01:59
android_man писал(а):
Пробовал разные версии питона, устанавливал megaPyModulePack и никак не решается эта беда.

Видимо эта программа удалила системные файлы, я не знаю точно в чём проблема, но это точно не Python.

android_man
Новичок
НовичокПолезность: 0 (0)
Имя: Владимир
Возраст: 34
С нами с: 08.03.2012
Сообщений: 6
0
746, добавлено: 27 Мар 2012 10:05
я уже перепрошивал фениксом и то же самое нет модулей "" а как еще можно восстановить эти системные файлы?

sokol851
Новичок
НовичокПолезность: 0 (0)
Имя: ilia
Возраст: 24
С нами с: 26.09.2011
Сообщений: 3
Откуда: РФ, Санкт-Петербург
0
747, добавлено: 06 Апр 2012 18:16
sokol851 писал(а):
Здравствуйте, как удалить полностью Python с Symbian, все куски и тд? Чтобы не было ничего связанного с ним.

Причина: Установил Python 2.0 поверх 1.4.5, после чего перестали запускаться некоторые приложения.

Цель: Удалить полностью битый Python, чтобы установить нормальный, более проверенный Python 1.4.5.

Тело: 5530

Опрос: какая версия Python лучше?

2.0.0 или 1.4.5


Или посоветуйте хорошую сборку Python для Symbian 9.4

Спасибо

Сброс не предлагать


АААА, помогите не молчите))

RuSlanch1k
Новичок
НовичокПолезность: 0 (0)
Имя: Руслан
Возраст: 28
С нами с: 26.01.2011
Сообщений: 12
Откуда: Укр., Мариуполь
Модель телефона: S.e.w902; Nokia N73; 5800
0
748, добавлено: 17 Мая 2012 16:36
Не могу установить Python на 5800,при установке,пишет ошибка обновления,все это началось после перепрошивки на http://www.forum.allnokia.ru/viewtopic.php?p=2855537#2855537,жду вашей помощи и советов!

anton226752
Новичок
НовичокПолезность: 0 (0)
Имя: Anton
Возраст: 30
С нами с: 17.05.2012
Сообщений: 1
Откуда: Укр., Львов
0
749, добавлено: 17 Мая 2012 21:01
Скажите пажалуста NOKIA 603 поддерживаєт функцию прасмотра відео через браузер в интернети єслі да то напишите какую програмку нужно скачать штоб через оперу можна било смотреть відео онлайн

Nokiandr
Новичок
НовичокПолезность: 0 (0)
Имя: Nokiandr
Возраст: 25
С нами с: 20.05.2011
Сообщений: 17
Откуда: Укр., Харьков
Модель телефона: Nokia X6_00
0
750, добавлено: 01 Июн 2012 10:43
Добрый день. Помогите, пожалуйста, исправить следующую проблему: Нужно установить Python 1.9.4 (или же 1.9.5) на смартфон с ОС Symbian 9.4 (s60v5). Скачал с отсюда. Но при установке - ошибка при обновлении. Ранее стоял SuperPython, но я его удалил со всеми хвостами. В Диспетчере приложений нет кусков питона. Не устанавливаются именно эти 2 версии питона. Например, Python 2.0 я легко установил. Но мне для приложения Sun&Moon Calc v.1.1.4 нужны именно эти версии. Не хотел бы форматировать диски - там уже много установленных прог. Помогите...


Новая тема Написать ответ На страницу 1...48495051 52
Часовой пояс: 3




Другие мобильные клубы
Samsung клубSony Ericsson клубSiemens клуб