ГлавнаяФорумДневникиФотоальбомы

Войти через:
Новости Телефоны Игры Графика Программы Документация Еще ...


Программа QT Installer


Данная программа для смартфонов Nokia является установщиком рабочих компонентов кросс-платформенного инструмента разработки программного обеспечения Qt на языке программирования C++. Запустите программу QT Installer на Вашем смартфоне и в результате чего будут автоматически установлены необходимые библиотеки с 19 сapabilities (полномочиями), содержащиеся в этом файле и требующиеся для поддержки работы приложений, написанных с помощью инструментария Qt.

Устанавливаемые компоненты:
» Stdcpp (Standard C++ library Common)
» OpenC_SSL (Open C LIBSSL Common)
» PIPS (PIPS Installer)
» Qt (Qt libraries)
» QtWebkit (QtWebkit library)

[!] В архиве находится дополнительная библиотека QT mobility версии 1.1.3, требуемая для корректной работы большинства приложений на базе QT.
Программу qmlviewer из архива можно не устанавливать - это приложение для разработчиков.

Разработчик: Nokia, Qt
Скачать QT Installer
Программы для смартфонов
АвторСообщение
winlog
1, добавлено: 23 Дек 2010 13:13
А для чего собственно это нужно? что оно в итоге даст?

no8ectu
Новичок
НовичокПолезность: 0 (0)
Имя: Anton
Возраст: 34
С нами с: 27.11.2011
Сообщений: 124
Откуда: РФ, Апатиты
Модель телефона: Nokia n8 Silver
0
511, добавлено: 23 Янв 2014 12:27
а как узнать, какая версия QT библиотек стоит в телефоне?
Nokia5110_Siemens m55_Nokia 5310_Nokia n8

AARWEN
Новичок
НовичокПолезность: 0 (0)
Возраст: 33
С нами с: 30.03.2014
Сообщений: 1
Откуда: РФ, Омск
0
512, добавлено: 06 Июн 2014 16:03
Спасибо! Спасибо!Спасибо! Телефон глюкануло, вернули к заводским настройкам, а там Qt компонент не установлен. Вы меня спасли!!!!!!!!

Влащ
Начинающий
НачинающийПолезность: +2 (2)
Имя: Сергей
Возраст: 28
С нами с: 14.10.2008
Сообщений: 108
Откуда: РФ, Хабаровск
Модель телефона: n86
0
513, добавлено: 06 Авг 2014 10:38
Ребята, очень надеюсь на вашу
помощь. Сделал полный сброс
телефона через 3 клавиши, открыл
полный доступ, скачал на нашем
сайте библиотеки qt (qmlviewer.sis,
qt.sis, qtmobility.sis, qtwebkit.sis), но при установке приложений на них,
мне постоянно выдает ошибку
"обновитесь до qtwebkit 4.08", хотя
именно эту версию я и установил.
Библиотеки ставлю в память
телефона. Помогите пожалуйста разобраться. Symbian Anna. Версия ПО
025.007
6610i=>6230=>6230i=>6233
=>7390=>n73=>n79=>n55=>n86

xala
Модератор
<b>Модератор</b>Имя: Михаил
Возраст: 52
С нами с: 03.11.2010
Сообщений: 15207
Откуда: Укр., Хмельницкий
Модель телефона: Xiaomi Redmi Note 4X Snapdragon

Влащ
Начинающий
НачинающийПолезность: +2 (2)
Имя: Сергей
Возраст: 28
С нами с: 14.10.2008
Сообщений: 108
Откуда: РФ, Хабаровск
Модель телефона: n86
0
515, добавлено: 06 Авг 2014 12:11
Забыл уточнить, у меня n8. Можно просто скачать самую верхнюю ссылку или все качать? И как мне удалить эти не родные библиотеки?
6610i=>6230=>6230i=>6233
=>7390=>n73=>n79=>n55=>n86

xala
Модератор
<b>Модератор</b>Имя: Михаил
Возраст: 52
С нами с: 03.11.2010
Сообщений: 15207
Откуда: Укр., Хмельницкий
Модель телефона: Xiaomi Redmi Note 4X Snapdragon
0
516, добавлено: 06 Авг 2014 18:10
Влащ,
Что бы не мучиться - лучший вариант прошить телефон.(дело 5 минут).
Если не хотите прошивать - делайте хард ресет кнопками и устанавливайте все QT по ссылкам.

Влащ
Начинающий
НачинающийПолезность: +2 (2)
Имя: Сергей
Возраст: 28
С нами с: 14.10.2008
Сообщений: 108
Откуда: РФ, Хабаровск
Модель телефона: n86
0
517, добавлено: 07 Авг 2014 05:30
Я в армии нахожусь, реально ли прошить без компьютера или нет?
6610i=>6230=>6230i=>6233
=>7390=>n73=>n79=>n55=>n86

xala
Модератор
<b>Модератор</b>Имя: Михаил
Возраст: 52
С нами с: 03.11.2010
Сообщений: 15207
Откуда: Укр., Хмельницкий
Модель телефона: Xiaomi Redmi Note 4X Snapdragon
0
518, добавлено: 07 Авг 2014 06:56
Влащ писал(а):
реально ли прошить без компьютера или нет?

Нет.

TheSasha2411
Новичок
НовичокПолезность: 0 (0)
Имя: Александр
Возраст: 22
С нами с: 29.05.2013
Сообщений: 32
Откуда: Костопіль
0
519, добавлено: 24 Окт 2014 18:58
Где и какую версию скачать для н73, ато есть пару прог которые требуют qt

GLB
NokiaMan
NokiaManПолезность: +202 (204)
Имя: Gleb
Возраст: 49
С нами с: 18.02.2010
Сообщений: 5938
Откуда: Укр., Киев
Модель телефона: BB Passport
0
520, добавлено: 24 Окт 2014 22:58
TheSasha2411, Попробуйте поискать на ЭТОМ сайте.
5800, L620, L630, L735+DS-903, L730DS

V1T@$
Новичок
НовичокПолезность: 0 (0)
Возраст: 32
С нами с: 12.11.2013
Сообщений: 15
Откуда: РБ, Минск
Модель телефона: 6.1+ & 730 & 5230 & 7200 & 1100
0
521, добавлено: 03 Дек 2014 01:29
Всем добрый..! а где в 5230 увидеть это:
Open C LIBSSL (2шт)
PIPS installer
Standard С++ (2шт)
Symbian OS Pipers Upgrade
Symbian OS PIPS Upgrade
sqlite3
??
нужно это найти и удалить! пока только удалил через Диспетчер прилож. все виды QT, а этих там нет...

Добавлено через 5мин. 21сек.
З.Ы. всё началось с того, что решил установить Вайбер на Нокью, а для него нужны эти QT... В итоге поставил вроде как все QT, собранные в 1 файл, но не всё из этой сборки установилось из-за сертификатов (не подумал включить нужный патч). После включения патча попытался обновить QT по-отдельности, но выскакивала ошибка типа невозможно обновить! В итоге решил нахер всё снести эти QT и поставить их по-одному заново, но как от них целиком и полностью очистить смарт теперь!??
ты хорошо подумал?

GLB
NokiaMan
NokiaManПолезность: +202 (204)
Имя: Gleb
Возраст: 49
С нами с: 18.02.2010
Сообщений: 5938
Откуда: Укр., Киев
Модель телефона: BB Passport
0
522, добавлено: 03 Дек 2014 08:05
V1T@$, https://forum.allnokia.ru/viewtopic.php?p=3235541#3235541
Попробуйте вариант установки через магазин. Устанавливаете любое бесплатное приложение, для которого нужны QT, из магазина, а библиотеки установятся паровозом. Но должна быть включена передача данных и потянет около 15Мб трафика.
5800, L620, L630, L735+DS-903, L730DS

V1T@$
Новичок
НовичокПолезность: 0 (0)
Возраст: 32
С нами с: 12.11.2013
Сообщений: 15
Откуда: РБ, Минск
Модель телефона: 6.1+ & 730 & 5230 & 7200 & 1100
0
523, добавлено: 06 Дек 2014 02:18
GLB писал(а):
Попробуйте вариант установки через магазин. Устанавливаете любое бесплатное приложение, для которого нужны QT, из магазина, а библиотеки установятся паровозом. Но должна быть включена передача данных и потянет около 15Мб трафика.

я ни разу не пользовался магазином - как в него заходить и правильно устанавливать?) понимаю, что вопрос чайниковский, но всё же)
или просто заходить на http://store.ovi.com, качать нужное приложение в формате .sis и устанавливать как обычное приложение?? но как тогда он установит паровозом дополнительные компоненты (те же QT)?

Добавлено через 1мин. 43сек.
или речь идёт о заходе на http://store.ovi.com именно с телефона, а не компа, и установке по телефону?? если так, то иначе никак по компу?!

Добавлено через 1ч. 10мин. 54сек.
жесть! зашёл в магаз, решил попробовать качнуть Вайбер оттуда по кабелю сразу в телефон - но кнопка ЗАГРУЗИТЬ не активна и серого цвета!!! Чё делать, как закачать приложения, если кнопка не активна?))
з.ы. вход в учётную запись магаза выполнен, Нокиа сюит также запущен, телефон подключен!
ты хорошо подумал?

wall637
Эксперт
ЭкспертПолезность: +136 (162)
Имя: Валентин
Возраст: 40
С нами с: 30.12.2007
Сообщений: 4008
Откуда: Самара
Модель телефона: Samsung Galaxy Note 8
0
524, добавлено: 06 Дек 2014 09:39
V1T@$, непосредственно с телефона зайдите в магазин. с компа может не получиться
Любая подпись хочет чтобы ее считали автографом.

GLB
NokiaMan
NokiaManПолезность: +202 (204)
Имя: Gleb
Возраст: 49
С нами с: 18.02.2010
Сообщений: 5938
Откуда: Укр., Киев
Модель телефона: BB Passport
0
525, добавлено: 06 Дек 2014 10:15
V1T@$ писал(а):
или речь идёт о заходе на http://store.ovi.com именно с телефона, а не компа, и установке по телефону?? если так, то иначе никак по компу?!

Да, я имел ввиду зайти именно с телефона через приложение Магазин Нокиа(само приложение должно быть обновлено до последней версии). Сейчас попробовал зайти с 5800 - Вайбер доступен и кнопка Установить активна. Попробуйте установить другое приложние. Например Talking Hamster. С ним тоже устанавливаются QT. Если всё нормально установится, хомяка может удалить и устанавливать Вайбер.
Через Нокиа сьют вообще не могу зайти в магазин, но это, скорее всего проблема с моим сьютом(давно не обновлял). Но в любом случае, даже при установке приложения через сьют, QT будут качаться по сотовой сети. После установки приложения появится сообщение, что необходимо установить дополнительные компоненты или что-то в этом роде. Без сотового трафика из магазина ни как. Ну и чтобы всё нормально установилось и работало, предварительно должны быть удалены все хвосты QT от предыдущей установки.
Вы, кстати, первый раз устанавливали QT через инсталлер с оллнокиа? Там есть две папки - для Symbian^1 и Symbian^3. Вам нужны для Symbian^1. Некоторые по ошибке устанавливают из Symbian^3. Естественно, там и список для чистки немного отличается. Ну а самый идеальный вариант для чистки - хард ресет.

УПД При установке QT через магазин есть один минус. Если не изменяет память, нет возможности выбора памяти при установке. Устанавливаются исключительно в память телефона. Потому должно быть 25-30Мб свободной памяти.
5800, L620, L630, L735+DS-903, L730DS


Новая тема Написать ответ На страницу 1...333435 36
Часовой пояс: 3




Другие мобильные клубы
Samsung клубSony Ericsson клубSiemens клуб